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Processing NMR data using MestRe-C v 2.3a

You have probably already processed a lot of NMR data at the spectrometer (Varian or

Bruker) without even realizing it.  In order to display the results of your NMR experiment

on the Varian, for example, you typed wft and the result was your Fourier Transformed

spectrum.  wft is a command that means do a weighted Fourier transform of your fid.

Simple processing macros present in Varian or Bruker software allow you to quickly

examine your data; however, they are somewhat limited in their ability to produce a good

spectrum.  Additionally, they can take a lot of time to get the job done.

A number of other NMR data processing packages exist (some free, others require a fee).

NMRPipe, Felix, Mestre-C, Nuts, Sparky are just a few programs that are readily

available.  In this demonstration, we will use MestRe-C to demonstrate the principles of

data processing.

I.  Open your fid using Mestre-C.

File-Import Spectra- File Name fid -  go to the directory that contains your fid and open

the fid.  Select file type VarianVXR-Unity. You will see the decaying exponential that is

your fid.  Edit-Spectum Properties – A new window will appear detailing some of the

properties of the FID and how it was acquired:  spectrometer frequency, spectral width, #

data points, etc.  Click OK when  you are finished viewing the properties.  Now you must

process it.

II.  Processing the FID

Processing involves mathematical manipulation of the fid into the final Fourier

transformed result.  Typical things you may want to do are:

1. Apodization:  Here you apply a function to the fid to smoothly bring the decaying

exponential to zero as quickly as possible without cutting off signal.  There are

many different apodization, or window functions, you can apply to the fid to

change the appearance of the  transformed spectrum, the signal-to-noise (S/N) and

the resolution.  We’ll see the effect of applying different functions: line

broadening (exponential multiplication), Gaussian multiplier, trapezoidal

multiplier,

2. Solvent convolution: the solvent peak, typically H2O, is often broad and can

obscure important 
1
H signals in a 

1
H spectrum.  Presat or WATERGATE pulses

are not perfect.  Solvent suppression helps improve the appearance of the

spectrum.

3. Phasing: zeroth and first order phasing.

4. Baseline correction

5. Drift correction

We can interactively see the results of the window function on the fid by looking at the

Fourier Transform in real time.  We can also use a signal/noise meter to evaluate S/N for

different window functions.  The following exercise demonstrates the difference in

weighting functions and their effects on a spectrum.



Interactive weighting in the time domain:

You can apply apodization functions and see the effect directly on the FID without the

Fourier Transformation. In order to do this, select the command Process/Apodize. Now

you will get the Apodization dialog box.  Select the “exponential” function from the

drop-down menu, add line-broadening (LB) of 2.0 Hz, and press APPLY.  In the upper

window you will see the exponential function (red) and the apodized FID.  The apodized

FID will also appear in the bottom window.  Click OK to close the window.

Processing FID and examining result of FT spectrum

Click Process->Fourier Transform.  In the new window, you can change the number of

points to be Fourier transformed in the drop-down menu (i.e. increase this number to

“zero-fill” the Fid) or leave as is.  For now, the “Quadrature” and “Drift Correction”

boxes should be checked.  You can check or uncheck the “Autophase Correction” as you

like (feel free to experiment!).  Then click OK to do the Fourier Transform.  The

spectrum will appear.  You can move it up/down on the screen as necessary using the left

mouse button.  Re-load the FID and change some of the parameters in the Fourier

Transform window to see how they function/affect the final spectrum.

Load a new FID, as before, and bring up the apodization dialog box (Process/Apodize).

Click on the “Options” box.  Experiment with the exponential function.

Increase/decrease the LB, and note the changes in the S/N box.  Fourier Transform the

FID’s and note the changes in linewidth with different values of LB (try 1, then try 20 for

LB and note the changes in the Fourier transformed spectrum).

Experiment with some of the other functions:

Exponential Multiplier

f(t) = exp( - Rt )

Gaussian multiplier

f(t) = exp( - Rt
2
 )



The Gaussian function has a much faster decay from the peak and narrower wings than

Lorentzian lines.

Lorentz-to-Gauss resolution enhancement

f(t) = exp(+Ret).exp( - Rgt
2
 )

This function is not directly implemented in MestRe-C, but you can apply it by checking

both the Exponential and Gaussian multiplication functions and introducing a negative

value for the Exponential line broadening (Re) and a positive value for the Gaussian

parameter (Rg).

Sinebell

f(t) = sin (  + (180 - ) t / T ) T = Acq. Time

This function is very useful for magnitude spectra because it reduces the dispersive part

of the line shape.  It is also convenient for COSY-like experiments because it emphasizes

the sine-modulated cross peaks compared with cosine-modulated diagonal peaks.

Do not use this function to apodize a standard 
1
H spectrum because it will decrease the

signal.  Be careful when using this function in phase-sensitive experiments because it

generates line shapes with strong negative side lobes and near zero integral.

Phase-shifted sinebell, or cosine bell

=90°

This function is commonly used in 2D HSQC experiments.



Sinebell squared

f(t) = sin
2
 (  + (180 - ) t / T ) T = Acq. Time, =0°

Cosine bell squared

Same as above with =90°

After familiarizing yourself with the weighting functions, make the following further

adjustments to the spectra.

Phase correction

Click Process->Phase Correction->Phase Correction and the Phase Correction

window appears.  Use the Zero Order “clock dial” to adjust the zeroth order phasing.

Then use the first order “clock dial” to adjust the first order phasing.  If you make a

mistake and want to start phasing over, re-load the FID and start over.  Experiment with

the phasing parameters.  You can also define a “pivot point” by moving the slider bar

(sometimes a large peak in the spectrum is a good pivot point).  When phasing is

complete, click OK.

Manipulating the spectrum.

1. Vertical offset: To move the spectrum up or down the page, make sure there are

no tools selected and move the cursor to the baseline of the spectrum (outside the

label along the y-axis).  A small hand will appear and you can then click on the

left mouse button and drag the spectrum up or down.

2. To increase or decrease the vertical scale use the + and – buttons on the tool bar.

3. To enlarge a portion of the spectrum, choose the magnifying glass on the toolbar.

Hold the left mouse button down and drag the cursor across and up/down. A box

will form around the area, which will be enlarged when you let go of the left

mouse.  Click Full to return to the full spectrum.  To exit the zoom function, click

the magnifying glass tool again.

4. To scroll horizontally through the spectrum, there is a slider bar below the main

window (and below the x-axis labels).



Picking Peaks

To pick peaks click Tools->Peak Picking->Peak by Peak.  Now click the peaks

in the spectrum that you wish to identify and their chemical shifts will appear in a new

“peak list” window (spreadsheet).  To exit the peak picking option, click on the tool

again.  To view the list of selected peaks, click Tools->Peak Picking->Edit Peaks.  The

spreadsheet will pop up that lists the peak number, chemical shift in ppm, Hz, points, and

the peak height.  You can copy this table to an Excel spreadsheet for further

manipulation.  Click Close to close this window.

Referencing the spectrum

Click Tools->Reference and a window appears or click on the icon on the toolbar

with the letters TMS.  Your cursor now has the letters TMS next to it.  Place the cursor

over the peak you wish to reference, which will either be the TMS peak or the solvent

peak.  When you click on this peak a box will appear with a list of reference values.  In

the Solvent Signals box, click the appropriate solvent or define a new solvent and

chemical shift.  Click OK.  If this window does not close, click Close.

Baseline correction

Before you integrate the peaks you should carry out a baseline correction to give a

smooth baseline. From the Process menu go to Baseline Correction and choose two-point

baseline correction.  Your baseline correction will then be done automatically.  If this

does not work choose the next option on the Baseline Correction menu, i.e. multi-point

baseline correction.  The box, which appears, gives instructions as to what to do.  You

can apply a function up to a 7
th

 order polynomial to flatten the baseline.  The manual

baseline correction can also be used for greater control.

Integrating peaks

Before you integrate the peaks you should carry out a baseline correction to give a

smooth baseline.  To integrate the peaks go to the Tools menu and highlight Integration.

From this menu choose “Integrate”.  The cursor will now have an integral sign next to it.

To integrate a peak hold down the left mouse button and drag the cursor over the peak

and then let go the mouse button. The peak is now integrated. Repeat this for all the

peaks. If you make a mistake with an integral you can go back to the Tools-Integration

menu and choose “Delete All Integrals”.  If you only want to delete one integral then

deselect the Integration icon on the tool bar (it has a picture of an integrated peak on it).

Then click on the integral you want to remove to select it, and press delete.  The integral

should now be gone.  To make integrals bigger or smaller use the up and down arrow

keys on the keyboard.

Printing the Spectrum or Pasting it in a Text Document

If you want to change things like the color of the spectrum or the font of the scale,

go to the Edit menu and choose Spectrum Properties.  There are a number of Display

Properties and Scale Properties that can be changed. When you have finished

manipulating your spectrum you may want to paste it into a Word document or print it

out on its own.  To paste it into a Word document go to the Edit menu and choose Copy.

Then open your Word document and in the Edit menu choose Paste.  Your spectrum



should now appear in the document but may have to be enlarged or reduced in size.  If

you want to print your spectrum from Mestrec you may first want to add text.  Choose the

icon on the tool bar with the letter A and a text box appears in which you can type a

caption for your spectrum.  To check what your spectrum will look like when you print it

go to the File menu and choose Print Preview.  In this screen you can reduce the size of

your spectrum that is to be printed.  Choose Close to get out of the print preview.  When

you want to print go to the File menu and choose Print.

Measuring coupling constants

In spectral window click Tools->Measure coupling constants.  A worksheet pops

up and when you roll over the spectrum with the mouse, peaks are selected and

highlighted in red.  Click on the first peak to measure the coupling constant and its value

in Hz appears in the spreadsheet.  Click on the second peak in the spectrum and its value

appears in the spreadsheet.  The coupling constant in automatically calculated.  Move the

cursor over the values in the spreadsheet to view the coupling constants on the spectrum.

The information in the spreadsheet can be copied into an Excel spreadsheet for further

manipulation.

Simulating a FT spectrum:

You can simulate spins in a spectrum.  Click Simulate->New.  Subsystem 1.

Number of spin groups: 2.  Lineshape: Lorentzian.  Set spectral width to be 3000 Hz

(Min. Freq. = 0, Max. Freq. = 0).  In spreadsheet-like window, for row A, specify a shift

in Hz, 500.  For row B enter 700 Hz.  For both spin A and B, enter “1” under “N”

(number of spins).  Use a spectrometer frequency of 300.  Click OK.  The result is the FT

spectrum of this two-spin system.  These spins show no J-coupling and are separated by

200 Hz.  If the spectral width is decreased to a value smaller than the chemical shift, an

alias SHOULD appear but in MestRe-C, the peak simply disappears.

To edit the simulation, click Simulation->Edit Simulation and the initial

window specifying parameters reappears.  To edit the simulated spectrum interactively

click Simulation->Interactive.  You can interactively change the spin’s resonant

frequency or the coupling constants.

To see the effect of multiple spins, click Simulation->Edit Simulation. Change

the number of spins  (“N”) for spin A from 1 to 3.  The frequency intensity at A is now

three times greater than B.  This frequency represents three times as many spins as

frequency B.
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